choose language

Viewing

Which devices are compatible with the Hair Coach?

Compatible OS

  • iOS 8.0 or higher 
  • Android 5.0 or higher

Compatible devices

  • iPhone 4S or higher
  • iPod Touch 5th Generation or higher
  • iPad (3rd Generation or higher, as well as any iPad Mini)
  • BLE (Bluetooth Low Energy) compatible Android device
Was this article helpful?
4 out of 6 found this helpful
Submit a request