choose language

Viewing

Which devices are compatible with the Withings Thermo?

Compatible OS

  • iOS 8.0 or higher
  • Android 5.0 or higher

Compatible Devices

  • iPhone 4s or higher
  • iPad (3rd Generation or higher, as well as any iPad Mini)
  • iPod Touch 5th Gen
  • Android 5.0 devices
Was this article helpful?
9 out of 11 found this helpful
Submit a request